Im loading a jquery file from googles api into wordpress. I recieve this error after i attempt to activate(hover over) anything JS related:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
Timestamp: Mon, 11 Apr 2011 04:39:53 UTC


Message: Member not found.

Line: 67
Char: 324
Code: 0
URI: http://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js?ver=1.4.4

I am not sure why it mentions anything about mozilla, but that's what is incorporated in the error log from online explorer 9. IE8 provides the same error too.

<?php 
    if( !is_admin()){
        wp_deregister_script('jquery');
        wp_register_script('jquery', ("http://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js"), false, '1.4.4');
        wp_enqueue_script('jquery');
    }
?>

Finish Result on FF, chrome, and then any broswer besides IE is:

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js?ver=1.4.4" type="text/javascript"></script>

What is weirder is the fact that 1 / 2 of my JS functionality works and also the partner does not. It features a hover effect along with a fade essentially after click. I have no idea what's wrong, so any help could be appreciated.