I am presently attempting to download an Apache Maven wordpress plugin for Eclipse in order to migrate a task from Ant. I have read numerous tutorial sites regarding how to install this wordpress plugin, and many of them present an update site. Regrettably, my Eclipse isn't finding the databases which are allegedly in the URL's I have received. Here are the a person's I have attempted:

http://m2eclipse.sonatype.org/sites/m2e/
http://download.eclipse.org/technology/m2e/releases/
http://mevenide.codehaus.org/maven-eclipse-plugin-plugin/

Sadly, many of these haven't proven helpful yet, so I am beginning to consider that possibly a particular setting is off or missing within Eclipse itself that's stopping it from finding these databases. Sometimes, though, it informs me that it's simply not able to see a repository. For instance, Eclipse spat out this error a couple of occasions when attempting to make use of http://m2eclipse.sonatype.org/sites/m2e/:

Unable to read repository at http://m2eclipse.sonatype.org/sites/m2e/content.xml.

At these times, it appears as if its "finding" the repository, however it cannot see clearly... As I have stated, I have adopted a number of instructions to installing the wordpress plugin, and none have labored because of this starting point. Any ideas?

m2eclipse has moved from sonatype to eclipse.

The correct update website is http://download.eclipse.org/technology/m2e/releases

If this isn't working, one possibility is you possess an older version of Eclipse (< 3.6). Another - if you notice timeout related errors - might be that you're behind a proxy server.