I am running apache / os x and serving up localhost pages to check django on my small laptop. I have already verified all of the following

• python is working fine and current (2.5.1)

• django open to python and current (1,1,, 'final', )

• mod_wsgi module is loaded among apache modules during my apache config - Check!

• road to django application is within vhost.conf with proper permissions - OK!

• mod_wsgi vhost.conf examined and dealing fine within the intended django application directory - test application through localhost pulls up 200 OK, 'hello world!'

• django default application continues to be produced using 'django-admin.py startproject mysite'

• django application works fine on port 8000 using development server - OK!

• road to the brand new django application (known as mysite) is on python path - verified!

All of this is verified so when I run the wsgi script with DJANGO_Configurations_MODULE configurations.py and load the django application, I get 'could not import configurations 'mysite.settings' etc.

Because this appears to pay for the fundamental troubleshooting, what are the further steps I possibly could decide to try discover the issue?


Python path applies, verified. The django development server runs fine using the command line on port 8000.

The apache config has got the typical module loaded: LoadModule wsgi_module libexec/apache2/mod_wsgi.so

vhost.conf is incorporated from apache config the following

NameVirtualHost: *.80

    <Directory /users/useracct/scripts/python>
            Order allow,deny
            Allow from all

    <Directory /Library/WebServer/Documents>
            Order allow,deny
            Allow from all
    WSGIDaemonProcess localhost user=username group=staff threads=25
    WSGIProcessGroup localhost

    WSGIScriptAlias /mysite /users/useracct/Sites/mysite/mysite.wsgi

    <Directory /users/useracct/Sites/mysite/>
            Allow from all

    DocumentRoot /Users/useracct/Sites/

Virtualenv isn't setup with this particular account, to ensure that is a less possible cause.


and also the wsgi script file (attempting to keep it minimal):

import os, sys
path = '/users/usracct/sites/mysite'
if path not in sys.path:

os.environ['DJANGO_SETTINGS_MODULE'] = 'mysite.settings'
import django.core.handlers.wsgi
application = django.core.handlers.wsgi.WSGIHandler()

Try adding /customers/useracct/Sites/ a for your pythonpath inside your wsgi file:

import os
import sys
sys.path.append(os.path.dirname(os.path.abspath(__file__)) + '/..')