I have just installed SQL Server 2008 Developer edition and I am attempting to connect using SQLCMD.exe, however i obtain the following error:

H:>sqlcmd.exe -S ".SQL2008"

Monosodium glutamate 18452, Level 14, Condition 1, Server DEVBOXSQL2008, Line 1

Login unsuccessful. The login comes from an untrusted domain and can't be utilized with Home windows authentication.

Has anybody seen this before? Any idea what it really means??

I'd this problem also it was since the machine running the applying is not reliable for delegation around the domain by active directory. If it's b .internet application running under a credit card applicatoin pool identity DOMAIN_application.atmosphere for instance.. the identity can't call people to SQL unless of course the device is reliable.

You are not passing any qualifications to sqlcmd.exe

Therefore it is attempting to authenticate you while using Home windows Login qualifications, however, you should not have your SQL Server setup to simply accept individuals qualifications...

Whenever you were setting up it, you'd have needed to give you a Server Admin password (for that sa account)

Try...

sqlcmd.exe -U sa -P YOUR_PASSWORD -S ".SQL2008"

for reference, theres more particulars here...

Just attempted this:

H:>"C:Program FilesMicrosoft SQL Server90ToolsBinnsqlcmd.exe" -S ".SQL2008" 1>

and delay pills work.. (I've the Microsoft SQL Server100ToolsBinn directory during my path).

Still unsure why the SQL Server 2008 version of SQLCMD does not work though..

Would you specify a person title and password to go online? What is your complete command line?

If you are running by yourself box, you may either specify a username/password, or make use of the -E parameter to go online together with your Home windows qualifications (if individuals are allowed inside your SQL server installation).

Marc

Your error is very literally saying "you are attempting to use Home windows Authentication, however your login is not from the reliable domain". That is odd, because you are hooking up towards the local machine.

Possibly you are drenched into Home windows utilizing a local account as opposed to a domain account? Make sure that you are signing in having a domain account that's additionally a SQL Server principal in your SQL2008 instance.

I tracked this lower to a noticeable difference between a Home windows XP Home and XP Professional server. (Produced two almost-identical Virtual PC servers with SQL 2008 Express)

After I connect with the XP Home system it connects while using SERVERGuest account effectively.

After I attempt to connect with the XP Professional system, it fails using the 18452 error (Guest user is enabled and dealing).

The SQL Server (2008 Express) logins have the SERVERGuest account enabled?

How come XP Professional produce this error?