Hi Hopefully someone available could provide a clue on where you can here. Here's the issue.

I've enabled SSI in certain jboss under Solaris, I've the applying web.xml set up the following:

<filter>
	<filter-name>ssi</filter-name>
	<filter-class>
		org.apache.catalina.ssi.SSIFilter
    </filter-class>
	<init-param>
		<param-name>contentType</param-name>
		<param-value>application/xml(;.*)?</param-value> <!-- also have tried here html(;.*)? -->
	</init-param>
	<init-param>
		<param-name>debug</param-name>
		<param-value>0</param-value>
	</init-param>
	<init-param>
		<param-name>expires</param-name>
		<param-value>666</param-value>
	</init-param>
	<init-param>
		<param-name>isVirtualWebappRelative</param-name>
		<param-value>0</param-value>
	</init-param>
</filter>

  <filter-mapping>
	<filter-name>ssi</filter-name>
	<url-pattern>*.xsl</url-pattern>
</filter-mapping>
    <!-- the following mappings were inserted after -->
<filter-mapping>
	<filter-name>ssi</filter-name>
	<url-pattern>*.html</url-pattern>
</filter-mapping>

<filter-mapping>
	<filter-name>ssi</filter-name>
	<url-pattern>*.shtml</url-pattern>
</filter-mapping>

So my problem would be that the SSI is employed by XSL files although not for HTML files. Also I place the Context issues within the title since I've got a symbolic connect to my application.war in jboss the reason being I am utilizing a Content management systems and that i require the files to become published somewhere within the file system.

The 2 a few things i can consider this, is the fact that either is one thing playing track of my multiple filter mapping terms (that is most unlikely) and also the other the first is that jboss can't reload the context with this application.war

Also I put here some good info about Context.xml since i have think you may request for this

<?xml version="1.0" encoding="UTF-8"?>
<Context antiJARLocking="true" reloadable="true" privileged="true"/>

I'll appreciate any pointers, I can not evaluate which can it be

just transformed from filter to servlet and labored all right here's the code

<servlet>
	<servlet-name>ssi</servlet-name>
	<servlet-class>org.apache.catalina.ssi.SSIServlet</servlet-class>
	<init-param>
		<param-name>buffered</param-name>
		<param-value>1</param-value>
	</init-param>
	<init-param>
		<param-name>debug</param-name>
		<param-value>0</param-value>
	</init-param>
	<init-param>
		<param-name>expires</param-name>
		<param-value>60</param-value>
	</init-param>
	<init-param>
		<param-name>isVirtualWebappRelative</param-name>
		<param-value>1</param-value>
	</init-param>
	<load-on-startup>1</load-on-startup>
</servlet>