I am trying to produce a web site using Joomla and XAMPP.

I am getting Strict Standards in most areas of page... This really is annoying.

Strict Standards: Static function JDatabase::test() shouldn't be abstract in C:xampphtdocsJoomla17librariesjoomladatabasedatabase.php online 350

Strict Standards: Being able to access static property JCache::$_handler as non static in C:xampphtdocsJoomla17librariesjoomlacachecache.php online 394

Strict Standards: Being able to access static property JCache::$_handler as non static in C:xampphtdocsJoomla17librariesjoomlacachecache.php online 396

Yet another factor i attempted to alter php.ini file. I've two files in Joomla 1.7. php INI-Devlolpment php INI-Production

What is distinction between both?

I attempted many factor to change off strict standards:

display_errors

Default Value: Off

Development Value: Off

Production Value: Off

also

error_confirming

Default Value: E_ALL &lifier ~E_DEPRECATED

Development Value: E_ALL &lifier ~E_DEPRECATED

Production Value: E_ALL &lifier ~E_DEPRECATED

also

error_confirming = E_ALL &lifier ~E_DEPRECATED

also

display_errors = Off

Still i am getting these errors?

Help me to resolve this.. Thanks, Shanmugam

visit the file that create error and alter $this->_handler to self::$_handler

display_errors = Off

should work. To locate where it seted to On It's possible

  • php.ini
  • httpd.conf
  • .htaccess
  • php code

To be aware what files used as php.ini you should use phpinfo() and discover path php.ini there

Easiest fix for your problem is:

  1. Visit "administrator" window
  2. Under "global configuration" choose "server"
  3. In "server configurations" set "Error Confirming" to "none" or "simple".
  1. Stop Apache and mysql services ( you might want to get it done through SCM in Xampp user interface)

  2. open c:/xampp/php/php.ini

  3. find Display_Error

  4. you will find two records for Display_error the first is with in start that's a comment second without

  5. change Display_Error Off ( default it's On)

  6. Start the help back.

  7. http://localhost/joomla### also it should work.

**For individuals using Xampp 1.7.4, etc. the file is /opt/light/etc/php.ini

I am getting exactly the same error and attempted to fix it, but nonetheless possess the problem. :(
The php.ini appears like:

; allow_call_time_pass_reference
;   Default Value: On
;   Development Value: Off
;   Production Value: Off

; display_errors
;   Default Value: Off
;   Development Value: Off
;   Production Value: Off

; display_startup_errors
;   Default Value: Off
;   Development Value: Off
;   Production Value: Off

; error_reporting
;   Default Value: E_ALL & ~E_STRICT
;   Development Value: E_ALL | E_STRICT
;   Production Value: E_ALL & ~E_DEPRECATED

; html_errors
;   Default Value: Off
;   Development Value: On
;   Production Value: Off

-edit-

Resolved problem the following: Removing Xampp and setting up WampServer rather.

No error and dealing like no bodies business. )

open xampp/php/php.ini with WordPad, make Control+F type "Display_Error" push find, you will find two findings, yours is second. you will see display_errors line with "on" alongside it, just change it out to off, Control+s (you have to save). should work

run-C:xamppphpphp.ini open with Notepad, Control+H find: e_strict, changed:-empty- changed all save close.

During my php.ini within the XAMPP lines below

532 ;http://php.net/display-errors
533 display_errors = On

to

532  ;http://php.net/display-errors
533  display_errors = Off

Stopped after which restarted Apache server which result in the annoying errors disappear.