I've my server execute a yummy update every evening. Last evening, it up-to-date suPHP towards the latest version: Oct 16 01:25:43 Updated: mod_suphp-0.7.1-1.el5.art.x86_64

This update has triggered this site to throw a 500 internal server error. From what I have been capable of finding, I ought to just alter the latter lines during my suphp.conf file to incorporate quotes, that we did. But after restarting apache, I get error 500. None of my files or sites are going to 777, so that isn't the problem either. Does anybody else understand what has transformed within the latest suPHP release that will cause my config to no more work? Thanks. Here's what my conf file appears like now:

[global]
;Path to logfile
logfile=/var/log/suphp.log

;Loglevel
loglevel=warn

;User Apache is running as
webserver_user=apache

;Path all scripts have to be in
docroot=/

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=false
allow_file_others_writeable=false
allow_directory_group_writeable=false
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=true

;PATH environment variable
env_path=/bin:/usr/bin

;Umask to set, specify in octal notation
umask=0022

; Minimum UID
min_uid=500

; Minimum GID
min_gid=500

; Use correct permissions for mod_userdir sites
handle_userdir=true

[handlers]
;Handler for php-scripts
;x-httpd-php=php:/usr/bin/php-cgi
php5-script="php:/usr/bin/php-cgi"

;Handler for CGI-scripts
x-suphp-cgi="execute:!self"

I'm using atomic rocket turtle repos.

I fixed it. The next lines are deprecated, and so i just needed to remove it: handle_userdir=true