My symfony project is used on hosting that is shared on the sub-domain.

All not-guaranteed modules work fine, but no secure modules load, and also the routing fails tossing a Empty module and/or action... error. The routing is working acceptable for unauthenticated modules. I could not find much within the logs, exactly that the sfBasicSecurityFilter wasn't getting known as.

To resolve it,

  1. I adopted the answer within this ticket and added 'POST' towards the sfRequestRoute class
  2. I additionally attempted adding the sf_method requirement towards the routes
  3. The Auth module was earlier known as default, to avoid a title conflict I even transformed the module title
  4. I've totally reset the cache multiple occasions
  5. It really works fine on all local conditions.

Any solutions?

[EDIT] Another experiment I made use of the frontend_dev.php controller around the setup, and in comparison using the log from index.php

index.php when asking for the path /prices which comes from an unsecure module

May 23 12:37:38 symfony [info]  Connect sfRoute "sf_guard_signin" (/guard/login)

May 23 12:37:38 symfony [info]  Connect sfRoute "sf_guard_signout" (/guard/logout)

May 23 12:37:38 symfony [info]  Connect sfRoute "sf_guard_didn't remember_password" (/guard/didn't remember_password)

May 23 12:37:38 symfony [info]  Connect sfDoctrineRoute "sf_guard_didn't remember_password_change" (/guard/didn't remember_password/:unique_key)

May 23 12:37:38 symfony [info]  Match route "home_prices" (/prices) for /prices with parameters array (  'module' => 'home',  'action' => 'pricing',)

May 23 12:37:38 symfony [info]  Performing filter "sfRenderingFilter"

May 23 12:37:38 symfony [info]  Performing filter "sfCacheFilter"

May 23 12:37:38 symfony [info]  Performing filter "sfCommonFilter"

May 23 12:37:38 symfony [info]  Performing filter "sfExecutionFilter"

May 23 12:37:38 symfony [info]  Call "homeActions->executePricing()"

....

May 23 12:37:38 symfony [info]  Send status "HTTP/1.1 200 OK"

May 23 12:37:38 symfony [info]  Send header "Content-Type: text/html charset=utf-8"

May 23 12:37:38 symfony [info]  Send content (6444 o)

frontend_dev.php when asking for the path /prices which comes from an unsecure module

May 24 08:14:28 symfony [info]  Connect sfRoute "sf_guard_signin" (/guard/login)

May 24 08:14:28 symfony [info]  Connect sfRoute "sf_guard_signout" (/guard/logout)

May 24 08:14:28 symfony [info]  Connect sfRoute "sf_guard_didn't remember_password" (/guard/didn't remember_password)

May 24 08:14:28 symfony [info]  Connect sfDoctrineRoute "sf_guard_didn't remember_password_change" (/guard/didn't remember_password/:unique_key)

May 24 08:14:28 symfony [err]  Empty module and/or action after parsing the URL "/frontend_dev.php/prices" (/).

May 24 08:14:28 symfony [info]  Send status "HTTP/1. 404 Not Found"

I am using HTACCESS make it possible for routing /public_html/.htaccess (empty)

/public_html/demo/.htaccess

#RewriteEngine on

#RewriteBase /

#RewriteCond % !^/web/

#RewriteRule .* /web/%1 [QSA]

Options +FollowSymLinks +ExecCGI

<IfModule mod_rewrite.c>

  RewriteEngine On

  # we skip all files in /web

  RewriteCond % ^/web/

  RewriteRule .* - [L]

  # we rewrite other files with .something to /web

  RewriteCond % ..+$

  RewriteCond % !.html$

  RewriteRule ^(.*)$ /web/$1 [L]

  # !!! UNTESTED !!! ##################################

  # we see if the .html version is within /web (caching)

  #RewriteRule ^$ /web/index.html [QSA]

  #RewriteRule ^([^.]+)$ /web/$1.html [QSA]

  #####################################################

  # no, therefore we redirect to the front web controller

  RewriteRule ^(.*)$ /web/index.php [QSA,L]

</IfModule>

# large crash from your front web controller

ErrorDocument 500 "<h2>Application error</h2>symfony application unsuccessful to begin correctly"

/public_html/demo/web/.htaccess (empty)

Are you currently using sfGuardAuht? Have you performed "php symfony wordpress plugin:publish-assets" within the deployment?