I have researched this and should not appear to locate anything. I inherited a Frankenstein website lately that needed some changes. The website shows fine in most Opera, Chrome and IE7 and IE8 (in Home windows XP).

However, In IE9 (Home windows 7), I at random obtain a blank IE 404 page (not the 404 page not found file that you would get normally) though in some instances it replaces this content having a 404 error.

Here's the website : I did not construct it so do not judge me on using tables and non-standards compliant HTML and CSS. Regrettably the customer is strapped and isn't having to pay for any re-design.

One Accord Trucking Jobs

The website is really a mashup of Jamit software and WordPress.

I am not really sure why this really is happening. I can not find anything on the internet about IE9 carrying this out.

Well, for which it's worth, adding

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

towards the header files and fixing a few of the terrible markup have been effective, as close to I will tell.

You will find frames, iframes and pretty crappy standards within their coding, both around the front-end as well as on the rear finish. These were using loose like a doctype! Also there have been some strange conflicts with character encoding.

It had been also pretty random, and something particular fix did not help 100%, the 404 messages just happened less often. I have rejuvenated some of the problem pages 50+ occasions each without just one incidence so I am likely to say it's now fixed.

I really hope my fix helps someone else sooner or later.

Edit: Well, I'm not sure how you can set this as resolved. I suppose I can not set my very own response to resolved, so possibly somebody can publish and I'll set yours because the answer? Thanks!

Because you have WordPress integrated with exterior code, this seems like a scenario where wp-blog-header.php in WordPress may gratuitously set a 404 status header. A workaround for this would be to by hand totally reset the status header to 200 after needing wp-blog-header.php:


Another workaround is perfect for customers to uncheck the Advanced establishing Internet Options known as "Show friendly HTTP error messages". If that's unchecked, then IE will become other browsers, which seem to ignore a 404 code in instances where submissions are came back in the request.