I am following a "Getting-Began-with-Zend-Framework.pfd by akrabat as I am learning ZF. I've many years of experience of PHP although not ZF.

Around the Remove Album option. Basically click yes button I recieve a "This web site isn't available.", "Error 324 (internet::ERR_EMPTY_RESPONSE): Unknown error.". As though the server went lower. The server is well working and never heading down what exactly might be creating this?

I checked the remove controller along with other pages for bad web addresses or typos:

public function deleteAction() {
    // action body
    if ($this->getRequest()->isPost()) {
        $del = $this->getRequest()->getPost('del');
        if ($del == 'Yes') {
            $id = $this->getRequest()->getPost('id');
            $albums = new Application_Model_DbTable_Albums();
            $albums->deleteAlbum($id);
        }
        $this->_helper->redirector('index');
    } else {
        $id = $this->_getParam ('id',0);
        $albums = new Application_Model_DbTable_Albums();
        $this->view->album = $albums->getAlbum($id);
    }
}

I additionally checked the vista Script:

<?php
$this->title = "Delete album";
$this->headTitle ( $this->title );
?>
<p>Are you sure that you want to delete
'<?php echo $this->escape ( $this->album ['title'] ); ?>' by '
<?php echo $this->escape ( $this->album ['artist'] ); ?>'? </p>
<form action="<?php echo $this->url(array('action'=>'delete')); ?>" method="post">
<div>
<input type="hidden" name="id" value="<?=$this->album ['id']; ?>" />
<input type="submit" name="del" value="Yes" />
<input type="submit" name="del" value="No" />
</div>
</form>

I am unable to figure for that existence of me what's creating this. What am I missing?

I discovered it would be a typo within the class method within the applying_Model_DbTable_Albums:deleteAlbum. It had been calling itself (loopy-loopy, lengthy day sorry)