I am trying to setup an online host on my small Mac OS X 10.7 Installation. I am using VirtualHostX to handle my /etc/hosts and httpd-vhosts.conf file. Presently, my httpd-vhosts.conf file appears like this:

NameVirtualHost *:80

<Directory "/Users/yuval/Sites/mysite/">
Allow From All
AllowOverride All
</Directory>
<VirtualHost *:80>
    ServerName "mysite.dev"
    DocumentRoot "/Users/yuval/Sites/mysite"
</VirtualHost>

and my /etc/hosts files has this inside it:

# VHX START
127.0.0.1 mysite.dev
fe80::1%lo0 mysite.dev
# VHX STOP

I triggered Web Discussing under System preferences, and that i know apache is running. However, after i navigate either to 127...1 in order to mysite.dev, I recieve the next:

Forbidden

You do not have permission to gain access to / about this server.

My permissions on /Customers/yuval/Sites/mysite are 755. Attempting to change these to 777 did not help either. Observe that this really is happening with any folder I select -- I don't come with an .htaccess file in /Customers/yuval/Sites/mysite.

Update: Checking the apache error, fundamental essentials logs that appear:

[Fri Dec 09 17:59:27 2011] [error] [client 127.0.0.1] (13)Permission denied:
    access to / denied
[Fri Dec 09 17:59:27 2011] [error] [client 127.0.0.1] (13)Permission denied:
    access to /favicon.ico denied

It appears pretty apparent the vhosts + hosts code does its job in really identifying the address is available, but for whatever reason this is not working. Any ideas?

Make certain an index.html file is incorporated in the /Users/yuval/Sites/mysite/ directory.

OR enable directory indexing:

<Directory "/Users/yuval/Sites/mysite/">
  Options +Indexes
  Allow From All
  AllowOverride All
</Directory>

You may also set the DirectoryIndex choice to search for default files apart from index.html: http://httpd.apache.org/docs/current/mod/mod_dir.html

Edit

Saw your error message - this does not seem like a directory index problem.

Try chmod 755 around the /Users/yuval directory as pointed out within this ServerFault answer: http://stackoverflow.com/a/1241319/212700

Also look for any .htaccess files within the /Users/yuval/Sites/ directory as Apache will check individuals too.