I have visit a couple of other similar questions about here, but the majority of the solutions are Apache specific (coping with their .htaccess file) and I am using nginx.

I am getting trouble making my switch to the upload_max_filesize in php.ini stick. I am using nginx, php5 and wordpress on Debian.

After I run phpinfo() I begin to see the following output:

Loaded Configuration File /etc/php5/cgi/php.ini

Then i visit the relevant .ini file, change a couple of values, after which restart nginx. After I turn on a phpinfo() wordpress plugin I acquired for wordpress, it reviews the values as unchanged.

I am baffled because phpinfo() reviews that it's loading config values in the file that I have transformed, however it does not report the alterations.

You may be using FAST CGI:

[webserver] <----> [fcgi daemon]
                        `- [php]

Should you restart the webserver, PHP isn't restarted, so continues to have that old ini values since it did not reload the ini file.

Restarting the fcgi daemon solves that problem, PHP is going to be restarted, re-reading through the ini.

Some fcgi daemons possess a command that reloads the kid processes more beautifully. Is dependent on which you utilize.