This is actually the path of folder where are my web documents and which I wish to safeguard: "C:Program FilesPostgreSQLEnterpriseDB-ApachePhp/apache/www/MyWeb"

Also within this folder I placed: .htaccess and .htpasswd

My .htaccess has following: AuthName "Protected site" AuthType Fundamental AuthUserFile C:Program FilesPostgreSQLEnterpriseDB-ApachePhp/apache/www/MyWeb/.htpasswd require valid-user

In httpd.conf for DocumentRoot "C:Program FilesPostgreSQLEnterpriseDB-ApachePhp/apache/www" I transformed AllowOverrid None to any or all and added row AccessFileName .htaccess as below: AccessfileName .htaccess

Options FollowSymLinks AllowOverride None ----> All Order deny,allow Deny all

Making this things i did exactly!

And sorry for question I requested once more, becuase It appears in my experience that individuals answere on question only in first tem minutes, then it falls in oblivion. :)

Make certain the file is known as .htaccess, the journey states it's .htpasswd.

And you must have htaccess handling enabled inside your apache config. I believe this really is needed: AllowOverride AuthConfig

After couple of days I finally discovered that which was wrong with my configurations. First, Used to do huge mistake to not restart apache after every change I have done (AllowOverride All). And so do in your thoughts to get this done Should you rewrite something inside your httpd.conf...And 2nd factor I have not seen that it's wrong: is path during my .htaccess file where It ought to be written with " ". Because "Program Files" has space within the title between words.

I really hope my tips is going to be helpful for somebody with same issue maybe doing exactly same things wrong.