And So I have several devoted servers available running Ubuntu Lucid server. They mainly run WordPress sites - Light. However, among my original sites is really a controls engineering site that utilizes MathTex to render the equations.

MathTex is fairly difficult on servers. The engineering website is still located around the original VPS which runs something similar to CentOS (but that is irrelevant). The traffic and amounts of renderings that MathTex produces cause resource difficulties with my VPS. I have had the opportunity to allocate more assets towards the VPS but ultimately this will get costly. So Let me offload the equation rendering to my devoted servers which tend to be more effective and under-utilized.

So I have adopted the instructions on setting up and producing MathTex. And MathTex works fine in the command line. However, after i make an effort to call the script via my browser the browsers all try download the cgi file (I have examined on Opera and Chrome on 2 machines).

This brought me to try to compile and install on my small home Ubuntu box that's Ubuntu desktop. The command line works fine. However, again when calling the function during my browser it desired to download the file rather than rendering a formula. And So I moved the mathtex.cgi script to /usr/lib/cgi-bin. Still no go. I Quickly transformed /usr/lib/cgi-bin to 777 also it labored. I transformed /usr/lib/cgi-bin to 755 also it eliminate.

So home box works when /usr/lib/cgi-bin is 777. I attempted that certain of my devoted Ubuntu servers but still no go. My browser still tries to download the file.

The directive for Apache to obtain the cgi-bin directory is within /etc/apache/site-available/default. And also at a fast glance they seem to be identical (I've not yet analyzed every character).