I requested my host to upgrade from a classic PHP4 version towards the latest PHP version available 5.x.x (?) plus they explained I have to purchase a brand new server simply because they can't upgrade to PHP5 on Plesk 8..

My real question is: should not they have the ability to upgrade Plesk around the current server after which upgrade to PHP5?

I discovered this answer on the internet.