You will find some pages within this format:

http://www.saglikkosesi.net/soru-ve-yanitlari-goster?page=2

I would like these to come in this format:

http://www.saglikkosesi.net/soru-ve-yanitlari-goster/page/2

I made use of the next code inshtaccess:

Options +FollowSymLinks
RewriteEngine on
RewriteRule soru-ve-yanitlari-goster/page/(.*)/ soru-ve-yanitlari-goster?page=$1
RewriteRule soru-ve-yanitlari-goster/page/(.*) soru-ve-yanitlari-goster?page=$1 

Nothing transformed. So what can I actually do to repair this? (I personally use WordPress platform for my site. However I can't use permalink feature with this redirection because this pages are exterior pages and that i can't control them via Wordpress admin.)

Are you certain that .htaccess files are enabled because of your Apache configuration?

Incidentally, you accomplish that by setting AllowOverride All within the <Directory portion of your httpd.conf file.

You'll need RewriteCond to gain access to the query string and capture the appropriate part:

RewriteCond %{QUERY_STRING} ^page=(\d+)
RewriteRule ^/soru-ve-yanitlari-goster$ soru-ve-yanitlari-goster/page/%1?