I'm creating a Wordpress wordpress plugin that delivers updates within the widget portion of the page - everything works fine. The main one factor that does not may be the ajax callback (using load with jquery). It seems that Wordpress is obstructing direct accessibility php file that i'm attempting to load (it's in /wordpress-content/plug ins/myplugin).

How must i do this?

Are you able to not create a proxy script within the cause of your website to obtain the creation of that script simply by including it? e.g.:

<?php
include '/wp-content/plugins/myplugin.php';
?>