After adding an easy acl to the peak of default.vcl to limit purge demands to localhost, Varnish does not restart. My default VCL is otherwise unmodified. default.vcl is the following:

backend default {
  .host = "127.0.0.1";
  .port = "8080";
}

acl purge {
  "localhost";
}

It does not matter basically put the acl declaration below or above the after sales directive. Varnish version 3..2.

This ought to be a normally exteremely simple configuration.

Run varnishd in debug mode also it should demonstrate in which the error is. Example:

# varnishd -d -f /etc/varnish/default.vcl

Message from VCC-compiler:
Expected an action, 'if', '{' or '}'
('input' Line 32 Pos 6)
     resp.http.Cache-Control = "max-age=60";
-----#######################----------------

You may also make use of the compile flag (-C) to locate any syntax errors inside your VCL. This will not startup any servers, it really compiles the VCL into C and prints the output.

varnishd -C -f /etc/varnish/main.vcl