HELP! I simply setup an online host for 2 sites which have lots of traffic and i believe I simply screwed something up! This is actually the finish of my httpd.conf:

NameVirtualHost *

<VirtualHost *>

ServerName world wide web.mydomain.com

DocumentRoot /var/world wide web/html

</VirtualHost>

<VirtualHost *>

ServerName world wide web.mydomain2.com

DocumentRoot /var/world wide web/downloadr

</VirtualHost>

<VirtualHost *>

ServerName mydomain2.com

DocumentRoot /var/world wide web/downloadr

</VirtualHost>

I added the final virtual host to resolve the issue of mydomain2.com likely to wwww.mydomain.com. HOWEVER, what is happening now's that world wide web.mydomain2.com would go to world wide web.mydomain.com.

Help!!!

Thanks all

UPDATE

STUPIDITY beyond words - handled copying one site to 2 sites and therefore the two domain names pointing to the same location!! OMG this can not occur again. Make sure and recheck and recheck and recheck and recheck and recheck........

Btw, why would someone neg repetition me with this?

Rather than adding the 3rd virtual host, add

ServerAlias mydomain2.com

towards the second one. So that your entire configuration could be essentially this:

NameVirtualHost *

<VirtualHost *>

    ServerName world wide web.mydomain.com

    DocumentRoot /var/world wide web/html

</VirtualHost>

<VirtualHost *>

    ServerName world wide web.mydomain2.com

    ServerAlias mydomain2.com

    DocumentRoot /var/world wide web/downloadr

</VirtualHost>

If you would like demands for mydomain.com to really be rerouted to world wide web.mydomain.com, to ensure that the consumer sees the URL alternation in his/her browser, that you can do with mod_rewrite (but that is the topic of another question, search for this if you want)