I've uncomment the next in the php.ini file


Furthermore ,I've replicated the php_curl.dll to windowssystem32 and restart the apache server.

I'm testing the follwoing script


$buffer = curl_exec($curl_handle);

if (empty($buffer))
    print "Sorry, example.com are a bunch of poopy-heads.<p>";
    print $buffer;

and becoming the next error

Fatal error: Call to undefined function curl_init() in C:\wamp\www\t.php on line 3

any assistance will be appreciated ?

Make certain you have uncommented the extension in the right php.ini file. You can examine whether extension is enabled through phpinfo() command.

this sloved my problem

  1. Stop WAMP completely.
  2. Find your WAMP folder C:\Path\To\WAMP\bin\Apache\ApacheVersion\bin\
  3. Edit that php.ini and uncomment extension=php_curl.dll
  4. Restart WAMP.

Which should hopefully solve it.

As well as simpler, click on the wamp icon within the notification area (bottom right of the screen), undergo PHP > PHP extensions and click on the 2nd item 'php_curl'. Wamp will restart instantly.