I produced my WCF project and delay pills work fine after i just run it in the debugger.

However when I publish it to IIS and point a browser towards the svc the road used has localhost inside it. Such as this:

htpp://localhost/MyService/MyServices.svc

however the path the web page states to visit for that WSDL uses my computer title, such as this:

http://MyComputerName.MyDomain.internet/MyService/MyService.svc?wsdl

After I click the link it occasions out. (Also, attempting to see the services like this in WCFTestClient occasions out.)

However, basically go the wsdl using localhost it works immediately:

http://lcoalhost/MyService/MyService.svc?wsdl

Any link that utilizes my computer title occasions out ("takes too lengthy to replyInch).

Any idea regarding how to make my WCF service use the pc title?

(NOTE: I'm using Visual Studio Ultimate and IIS 7)

Try adding MyComputerName.MyDomain.internet for your proxy bypass list in Ie proxy configuration setting. Make sure that the IIS website has this FQDN in it's hostname within the site bindings.

Also what goes on should you just use MyComputerName with no domain ?