The WSHttpBinding with title WSHttpBinding unsuccessful validation since it consists of a BindingElement with type System.ServiceModel.Channels.SymmetricSecurityBindingElement that is not supported in partial trust. Consider crippling the content security and reliable session options, using BasicHttpBinding, or hosting the application inside a full-trust atmosphere.

The answer on the internet I discovered ended up being to switch to basicHttpBinging, but after doing it brought to being HTTP 404 error.

Can someone explain what's going wrong here.

My sample webservice url is http://highlyeasy.com/test/Services/service.svc

and web.config is

 <?xml version="1." encoding="utf-8" ?>

<bindings>

  <wsHttpBinding>

    <binding title="wsHttp">

      <security mode="None" />

    </binding>

  </wsHttpBinding>

</bindings>

<services>

  <service title="DNF.WCF.Service.CalculatorService">

    <host>

      <baseAddresses>

        <add baseAddress = "http://highlyeasy.com/test/Services/" />

      </baseAddresses>

    </host>

    <endpoint address ="" binding="wsHttpBinding" bindingConfiguration="wsHttp" title="wsHttpEndpoint" contract="DNF.WCF.Service.ICalculatorService">

      <identity>

        <dns value="highlyeasy.com"/>

      </identity>

    </endpoint>

    <endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange"/>

  </service>

</services>

<!--For debugging reasons set the includeExceptionDetailInFaults attribute to true-->

<behaviors>

  <serviceBehaviors>

    <behavior>

      <!-- To prevent revealing metadata information,

      set the worthiness below to false and take away the metadata endpoint above before deployment -->

      <serviceMetadata httpGetEnabled="True"/>

      <!-- To get exception particulars in problems for debugging reasons,

      set the worthiness below to true.  Set to false before deployment

      to prevent revealing exception information -->

      <serviceDebug includeExceptionDetailInFaults="False" />

    </behavior>

  </serviceBehaviors>

</actions>

The 404 error is most likely triggered by IIS not getting a configuration for svc files or asp.internet not enabled.

Try putting here's your web.config:

<buildProviders>

 <add extension=".svc" type="System.ServiceModel.Activation.ServiceBuildProvider,

      System.ServiceModel, Version=3..., Culture=neutral,

      PublicKeyToken=b77a5c561934e089"/>

</buildProviders>

Or even the 4. equivilent. Also make certain you have selected "integrated" mode within the advanced portion of the IIS management.