I'm hosting a website through godaddy.com and this is actually the link:

http://floridaroadrunners.com/

which is my web.config file:

 <?xml version="1."?>

<!--

  For additional info on how you can configure your ASP.Internet application, check out

  http://go.microsoft.com/fwlink/?LinkId=169433

  -->

<configuration>

  <connectionStrings>

    <add title="ApplicationServices"

         connectionString="databasesEquals.SQLEXPRESSIntegrated Security=SSPIAttachDBFilename=DataDirectoryaspnetdb.mdfUser Instance=true"

         providerName="System.Data.SqlClient" />

  </connectionStrings>

  <system.web>

    <compilation debug="true" targetFramework="4." />

    <authentication mode="Forms">

      <forms loginUrl="~/Account/Login.aspx" timeout="2880" />

    </authentication>

<customErrors mode="Off"/>

    <membership>

      <providers>

        <clear/>

        <add title="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="ApplicationServices"

             enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false"

             maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="" passwordAttemptWindow="10"

             applicationName="/" />

      </companies>

    </membership>

    <profile>

      <providers>

        <clear/>

        <add title="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="ApplicationServices" applicationName="/"/>

      </companies>

    </profile>

    <roleManager enabled="false">

      <providers>

        <clear/>

        <add title="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="ApplicationServices" applicationName="/" />

        <add title="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" applicationName="/" />

      </companies>

    </roleManager>

  </system.web>

  <system.webServer>

     <modules runAllManagedModulesForAllRequests="true"/>

  </system.webServer>

</configuration>

I'm getting runtime error:

Runtime Error

Description: A credit card applicatoin error happened around the server. The present custom error configurations with this application avoid the particulars from the application error from being seen remotely (for security reasons). It could, however, be seen by browsers running around the local server machine.

I've also set the customErrors mode = "off". What's wrong here? I'm using Visual Studio 2010 with 4. framework inside it. Thanks!

In case your host has allowed customErrors, you may consider catching and logging the exception yourself to help you see what's happening.

You will find a few options. First, try Elmah

Second, you could utilize your logging library (I love NLog, but any works), and catch the applying_Error event in Global.asax.cs.

protected void Application_Error(object sender, EventArgs e)

        does not realy allow us to, so we'll

            //try to find the inner exception

            Exception exception = Server.GetLastError()

            if (exception.GetType() == typeof(HttpUnhandledException) &lifier&lifier exception.InnerException != null)

            

            //obtain a logger in the container

            ILogger logger = ObjectFactory.GetInstance<ILogger>()

            //log it

            logger.FatalException("Global Exception", exception)

        

This is an excellent feature to possess regardless of what, even when you are capable of getting customErrors switched off.

The server's machine.config or applicationHost.config is probably overriding your web.config configurations. Regrettably there is nothing you are able to do in the event that's the situation, lacking getting in touch with GoDaddy's support line.

customErrors mode value Off is situation sensitive I believe. Book you have the very first character capitalized.