I am using Apache 2 and PHP 5 with WordPress. Which Apache Modules, PHP Extensions, and PHP Configurations must i switch onOraway?

Disable register_globals, leave everything else alone. Should work acceptable for wordpress.

Make certain mod_rewrite is enabled (whether it is not already), so that you can have fancy spinning.