I've Wamp placed on my local, two versions of PHP 5.2.9 and 5.3..

I had been experimenting using the php.ini apply for both versions when apache made the decision it wouldnt load any longer with PHP 5.3..

In Home windows event viewer it states:

Faulting application httpd.exe, version 5.2.11., time stamp 0x493f5d44, faulting module php5ts.dll, version 5.3.....

Where could I choose a new (uncorrupted) fresh php.ini apply for 5.3.?

Several versions of php.ini ship having a PHP download, look at your PHP installation directory for something similar to php.ini-dist and php.ini-recommended. Making a backup the next time. :)

You will find them within the PHP source repository at:

I suspect it is the "production" one which you are after.