I'm not acquainted with php4. Can you really operate a php4 file in Apache/2.2.11. anybody help me

For those who have PHP4 installed, sure, it will run. You should not though, for a lot of reasons.

If it's a very simple script, it might 'just work', however i doubt it. You should check the Backward Incompatible Changes document for many particulars.