That one has me stumped. I am implementing a Rails 3 application to Slicehost running Apache 2 and Passenger. My server is running Ruby 1.9.1 using RVM.

I'm getting a permission refused error around the "public" folder during my application. My Virtual Host is setup the following:

<VirtualHost *:80>

  ServerName  sharerplane.com
  ServerAlias www.sharerplane.com
  ServerAlias *.sharerplane.com

  DocumentRoot /home/robinjfisher/public_html/sharerplane.com/current/public/

  <Directory "/home/robinjfisher/public_html/sharerplane.com/public/">
    AllowOverride all
    Options -MultiViews
    Order allow,deny
    Allow from all
  </Directory>

  PassengerDefaultUser robinjfisher

</VirtualHost>

I have attempted these things: trailing slash on public no trailing slash on public PassengerUserSwitching off and on PassengerDefaultUser set and never set with and with no block.

The general public folder is possessed by robinjfisher:www-data and Passenger is running as robinjfisher and so i can't understand why you will find permission issues.

Does anybody have ideas?

Thanks

Robin

PS. Have disabled the website for the moment to prevent indexing what exactly can there be presently isn't the site under consideration.

Look at your actual home directory. /home/robinjfisher to make sure its "other" executable bit is placed. I.e., the dir has permissions of NN1 or greater where N is anything you like (i.e., 751 or 701).

I discovered the issue. I'd moved some js/css files relevant to some wordpress plugin and also the wordpress plugin ended up being attempting to re-install them because it could not locate them where it thought they must be.

I said the installation code and delay pills work fine now.

Robin