I am presently attempting to alter the Automatic WordPress Backup script to ensure that it may save files on the more consistent basis (about once every 6 hrs).

Right now I can not get results so any help could be much appreciated. In automatic-wordpress-backup I have added 'often' => 600 within the init function (line 51) in addition to adding 'Often' within the following code (line 369-373) :

<select name="s3b-schedule">
<?php foreach ( array('Disabled','Often','Hourly','Daily','Weekly','Monthly') as $s ) : ?>
    <option value="<?php echo strtolower($s) ?>" <?php if ( strtolower($s) == get_option('s3b-schedule') || ((get_option('s3b-schedule') === false || get_option('s3b-schedule') == '') && $s == 'Daily') ) echo 'selected="selected"' ?>><?php echo $s ?></option>
<?php endforeach; ?>
</select>

Using the entire code being quite lengthy I am unsure if I have to upload everything to here or maybe you'll look into the original package within the link provided above but when you'll need more details please tell me.

Thanks

I required a fast look.

To begin, try pastie.org and paste supply of wordpress plugin. I believe you will get far less solutions if people need to go download the wordpress plugin to see the origin. I required a fast look and also the changes you've made appear reasonable.

See line 59 in which the backup is scheduled using wp_schedule_event. This essentially states, go ahead and take value passed in in the admin form and backup about this schedule. If the is not working then install Fiddler and appearance the publish data getting sent in the wordpress plugin whenever you save your valuable changes. You need to call at your new 'often' option moving in. If it's being passed in, but nonetheless not running then consider the hook s3-backup (third param). Something should be failing inside.

Best of luck.