I get this error message while attempting to access a wordpress blog that is set up in a directory. Is because of .htaccess or something like that? Any assistance is appreciated.

'The server experienced an interior error or misconfiguration and was not able to accomplish your request.

Please contact the server administrator, website owner@xxxxx.com and tell them of times the mistake happened, and anything you may have done that could have triggered the mistake.

More details relating to this error might be obtainable in the server error log.

Furthermore, a 404 Not Found error was experienced while attempting to make use of an ErrorDocument to handle request.

Apache Server at xxxx.com Port 80'

This really is happening in my experience At This Time.

Regarding from things i know, my hosting companies did a DNS change and thus I am awaiting the DNS to propagate, it has been like three hrs but still zero.

Blog is showing ok, apache expires and dealing, I simply can't get access in to the Wordpress Admin area.

Whether it does get fixed by tomorrow, I'll reply here so it may be of help for other people.

Edit: I simply fixed my problem.

During my situation it had been determined the Fast Contact Page plug-in was creating the issue. I modified the folder title from si-contact-form to si-contact-form-hold i quickly obtained Wordpress Admin access.

Next I produced a php.ini file with this particular string inside 'memory=64MB' and saved that in to the wordpress-admin folder.

By hand erased the si-contact-form-hold (to prevent possible corrupted files) and reinstalled the short Contact Page.

My configurations were already there and things are back ready to go good!

Hope this can help.

More points

  • Blog continues to be running effectively. Just observed this issue since yesterday.
  • Blog is within a directory therefore it works something similar to this www.abc.com/blog. Apparently www.abc.com is working perfectly.

Update on logs

Getting both of these errors within the logs:

  1. File doesn't exist: /home/directory/public_html/500.shtml
  2. /home/sub-directory/public_html/sub-directory/.htaccess: RewriteCond: bad argument line '%!-f'
  3. /home/directory/public_html/sub-directory/.htaccess: # without matching # section

How do you restart apache on cpanel ?

I could repair it with the addition of the next line to my .htaccess file:

php_value memory_limit 128M

Russ

Regrettably it may be anything. Do static pages on the website work correctly.

Perhaps you have checked the server logs.

It is probably related to php. If static pages exist then possibly your config for wordpress is improperly set up or files missing.

Has php work? Did your blog work after which stop? Have you cope with the install process?

It may sound like you are benefiting from kind of PHP error but PHP is not set to show errors. You will want to look at your Apache logs for detailed error info.

The mostly likely reason is the fact that you are missing some prerequisite for running WordPress, although whatever you should certainly require is Apache, MySQL, &lifier mod_rewrite.

An HTTP 500 error might be triggered by a lot of things. Perhaps you have transformed your .htaccess file lately? By trying to utilize a .htaccess feature that's disabled in your host, that's one possible cause.

This really is more often than not an issue with your Apache configuration. Errors coming initially from in PHP won’t trigger the Apache 5xx handler, that is what you’re seeing.

Regrettably, without more details, your condition doesn't seem possible to identify. I’d suggest that you:

  1. Look into the logs. First factor! It will provide you with a better idea where your condition is.
  2. Stop and restart Apache. If there's an issue with permissions on something Apache needs write use of (logs), it might completely neglect to start. This will provide you with the proper motivation to repair the problem, especially if you will find other VirtualHosts on that Apache.
  3. Move your .htaccess file(s) elsewhere. If Apache works, you realize it’s an issue with that file.