I am using Wordpress the very first time and I am attempting to create my very own theme.

I've this issue: after i attempt to edit a webpage in the wordpress editor (tinyMCE) using html editor, each time I visit a new line it card inserts a <br> tag between your lines. I do not check this out within the editor, but simply right in front page.

For instance, I write this

<div class="span-8">
<div class="white_text shadow span-8 last" id="corsi_title">I nostri Corsi e Master</div>
<div class="subtitle span-8 last">Lorem ipsum dolor sit amet, consectetur adipiscing elit</div>
<div class="testo span-8 last">Morbi elementum, massa eget condimentum scelerisque, neque lacus ullamcorper magna, vel scelerisque lacus magna eu turpis.</div>
</div>
<div class="span-8 last">immagine</div>

and that i understand this around the top of the page

<div class="span-8">
<br>
<div id="corsi_title" class="white_text shadow span-8 last">I nostri Corsi e Master</div>
<br>
<div class="subtitle span-8 last">Lorem ipsum dolor sit amet, consectetur adipiscing elit</div>
<br>
<div class="testo span-8 last">Morbi elementum, massa eget condimentum scelerisque, neque lacus ullamcorper magna, vel scelerisque lacus magna eu turpis.</div>
<br>
</div>
<br>
<div class="span-8 last">immagine</div>
<br>

I have attempted lots of plug-inches or any other solutions but none of them labored!

The only real option would be to create all of the code within the same line, but this wolud be impossible for lengthy areas of code.

Shall We Be Held doing a problem, or missing something? Or perhaps is it a wordpress problem?

This issue is driving me crazy!