I simply imported my Wordpress database from the localhost installation on my small computer towards the online server. However, all of the links still indicate localhost rather than the server's url.

Can there be something extra I didn't remember to complete?

(Note: I didn't hard write my links so for instance the navigation which still indicates localhost is produced with this particular code:

<?php wp_list_pages('sort_column=menu_order&depth=1&title_li='); ?>

Some other example happens when I type the in url and kind "wordpress-admin/" after it to gain access to the dashboard, it redirects me towards the localhost dashboard page....really strange

You have to visit the wp_options table of the database (presuming wp_ is the WordPress table prefix) and alter the values from the fields with one of these option names, to mirror the place of the online server:

  • siteurl
  • home

You will definitely have to fix your configuration file.

http://codex.wordpress.org/Changing_The_Site_URL

You will find some values within the table wp_options which are Web addresses pointing for your site, and they should be up-to-date. To determine what ones, do

select * from wp_options where option_value like 'http://%';

During my installation those are the rows where option_name is siteurl or home.