I've three dynamic sidebars for my wordpress site. Sidebars 1 and a pair of work all right however the 3rd (groups) need icons and display them on the website however when I return to edit them in wordpress admin, it removes them. Any applying for grants this issue?

<?php
    // Sidebars
    add_action( 'widgets_init', 'my_register_sidebars' );

    if (function_exists('register_sidebars')){
        function my_register_sidebars() {
            // Widgets
            $before_widget = '<div id="%1$s" class="events %2$s">';
            $before_title = '<div class="purpleBarSpace"><span class="purpleBar">';
            $after_title = '</span></div>';
            $after_widget = '</div>';

            /* Home Sidebar */
            register_sidebar(
                array(
                    'id' => 'Home',
                    'name' => __( 'Home' ),
                    'description' => __( 'Sidebar for Homepage.' ),
                    'before_widget' => $before_widget,
                    'after_widget' =>  $after_widget,
                    'before_title' => $before_title,
                    'after_title' => $after_title
                )
            );

            /* General Sidebar */
            register_sidebar(
                array(
                    'id' => 'General',
                    'name' => __('General'),
                    'description' => __('All Purpose sidebar'),
                    'before_widget' => $before_widget,
                    'after_widget' =>  $after_widget,
                    'before_title' => $before_title,
                    'after_title' => $after_title
                )
            );

            /* Category Sidebar */
            register_sidebar(
                array(
                    'id' => 'Catgories',
                    'name' => __('Categories'),
                    'description' => __('Sidebar for Categories Page'),
                    'before_widget' => $before_widget,
                    'after_widget' =>  $after_widget,
                    'before_title' => $before_title,
                    'after_title' => $after_title
                )
            );
        }
    }
?>

Is it feasible the misspelling of "groups" for that id is leading to trouble?