I just read with the solutions on questions much like that one, and haven't found something that has resolved this problem.

I'm finding the following error on various pages on my small site.

Fatal error: Permitted memory size 16777216 bytes exhausted (attempted to allocate 7680 bytes) in [...]/wordpress-includes/taxonomy.php online 2930

The steps I have attempted to solve this are:

  • Request memory in wordpress-config.php with the addition of the road "define('WP_MEMORY_LIMIT', '256M')"

  • Boost the memory request PHP in php.ini by upgrading the road to "memory_limit = 256M"

  • Running phpinfo() notifies me the memory_limit is (so far as it thinks, I suppose) set at 256M.

  • Installed the

  • It appears in lowering the regularity of those errors by altering the flag in wordpress-config.php from:

    define('WP_CACHE', true); //Added by WP-Cache Manager
    

    to

    define('WP_CACHE', false); //Added by WP-Cache Manager
    

    but that is clearly not really a great solution, when i want caching enabled. Nevertheless, I could not even sign in before I made that change.

  • I installed the Wordpress-Memory-Usage plug-in: I am apparently using 33.58MB to see the wordpress-admin/dashboard

There's merely a couple of plug-inches installed, the website is on hosting that is shared, it receives maybe 5-10 sights each day.

Any ideas regarding how to resolve the memory problem? Could it be an problem using the cache? I've an e-mail to my webhost.

From experience, 16MB is very little for any Wordpress installation because it is - Wordpress simply is very body fat. Should you then possess a couple of plug ins running, you'll be certain to hit the limit frequently.

Maybe somebody can develop some memory saving tweaks, but failing that, I believe speaking for your provider and asking these to enhance the limit to 24 or (better) 32MB is the easiest method to go.