I've got a permalink working but the moment I produce a publish it informs me that soory publish not found permalink setting would be to "/%pagename%/" here is .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /ryan/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . ryan/index.php [L]
    </IfModule>
# END WordPress

Try clearing the permalink establishing wordpress_options within the database after which totally reset permalinks in Wordpress.

Have you got mod_rewrite placed on the server?

Look at your apache configuration and verify that for that directory that you store your Wordpress installation you've following configurations enabled (most likely you'll have more configuration choices for the particular directory, but fundamental essentials minimum needed for Wordpress fancy permalinks):

<Directory var/www/>
FollowSymLinks
AllowOverride All
</Directory>