I am running Wordpress 3..1 on the shared host using PHP5. I am getting issues uploading files which are just a little bigger through the media uploader within the admin portion of Wordpress.

Each time I attempt to upload personal files thats on the couple of mb, it uploads, states its crushing, then provides me with a large red-colored "HTTP Error." - anything.

This only happens on files which are just a little bigger - ie a 20mb .mp3 file. A 5mb file appears to operate fine. What is strange is previously we have submitted 40mb files with no problem.

--

Here's the steps I have taken to date to rectify the problem:

  1. Double checked php.ini to make sure increase upload, publish and memory size were sufficient.
  2. Up-to-date .htaccess to incorporate filter the safety mod I discovered elsewhere.
  3. Double checked all file permissions via ftp to make sure these were 755.
  4. Known as the host - "They do not support third party scripts" (I personally don't like IPower)
  5. Attempted with various audio recordings of comparable size.
  6. Disabled all plug ins

--

Do everyone have other great ideas regarding what may be leading to the vague "HTTP Error." problem?

Thanks ahead of time.

The issue, as is available already deduced, is incorporated in the size your file upload. Simply to help remind you, HTTP is not really designed for moving large files ... it can get it done, although not always, and not so well. You are encountering an problem where your host is reducing the transfer since the file is simply too large. It's probably a server setting somewhere you don't get access to.

Since "they do not support third party scripts" I am speculating you are inside a hosting that is shared atmosphere, and that's why something could change in your server without you doing anything. Possible solutions:

  1. Obtain a different host
  2. Make use of a devoted server
  3. Transfer your bigger files via FTP instead of from inside WordPress.

Put this line inside your wordpress-config file:

define('WP_MEMORY_LIMIT', '64M');