I have installed my wordpress site on the separate directory and adopted all of the steps described here and today I'm able to access my website from the primary domain. So, my Wordpress website is installed under: www.mysite.com/wordpress-site/ and today I'm able to access my website under www.mysite.com, so that all is excellent, precisely what I needed. Wordpress is causeing this to be happen with an .htaccess file it produces which has the required code to create the redirection happen (SEE CODE BELOW).

My issue is which i produce other sites on my small site, for example www.mysite.com/another-directory-unrelated-to-wordpress/ which i cannot access any longer because In my opinion wordpress and also the .htaccess file it produced is redirecting everything towards the root.

How do i avoid Wordpress from redirecting my other subfolders and files? Thanks a lot for just about any ideas or help.

This is actually the htaccess file code:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

How a WordPress .htaccess file works is that if a current file or directory is asked for, it will not send the request through WordPress...that is what the !-f and !-d RewriteCond claims do.

So, there's another thing happening together with your site. Perhaps you have used Firebug or other debugging tool to determine what's happening using the request/response?

You can always enable mod_rewrite logging to ascertain if that provides a clue.

<IfModule mod_rewrite.c>
RewriteEngine On

RewriteLog "rewrite.log"
RewriteLogLevel 3

RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

A RewriteLogLevel of 5 would provide you with the most information. Make certain to comment out or take away the RewriteLog* lines if you have determined the problem.

UPDATE: Check this other SO answer to ascertain if it resolves your problem