I'm using wordpress using this type of permalink:

/%year%/%monthnum%/%postname%/

basically use this kind of url: example.com/2010/03/तकनीक

it goodies this url such as this example.com/2010/03/ (By disregarding unicode chars) and shows March 2010 archive list.

basically use british url: example.com/2010/03/technology it works perfectly.

This issue happens even on tags page: for instance example.com/tag/इंटरनेट is treated like example.com/tag/ and shows 404 page.

Why wordpress is disregarding unicode chars?

Basically use default querystring structure it works perfectly despite unicode figures.

Server Info: IIS7 Win2008 Server (Url spinning enabled) Wordpress 2.9.2

For an introduction to the issue, review:

http://ruslany.net/2010/03/important-update-for-iis-7-0-fastcgi-module/

this refers you to definitely the now outdated:

http://ruslany.net/2010/02/fastcgi-module-differences-across-iis-versions/

My very own situation was fixed by using Win 7 SP1 but, oddly enough, I had been quit with using the registry hack that's referred to within the Hotfix:

http://support.microsoft.com/kb/2277918

I'm running WAMP server on local machine. I examined $_SERVER['PATH_INFO'] on my small IIS7 web server and located it has some unicode problem. Wordpress uses path_info to deal with web addresses. I produced personal files test.php with following code:

header('Content-type: text/html charset=utf-8')

echo $_SERVER['PATH_INFO'] ?>

Basically request http://example.com/test.php/कुछशब्द/कुछऔरशब्द/british

i quickly understand this output

----**----

/???????/?????????/british ----**---- path_info is transforming unicode hindi chars to ?????. Which means there's some condition in path_info variable during my server. Are you aware any setting IIS7 that induce this particular problem?

Exactly the same code works perfectly fine on my small local Apache Home windows server.