I am attempting to modify my wordpress theme (inove) to show all comments within the same page rather than 50 comments per page.

I opened up your comments ought to.perl file, said out calls to paginate_comments_links() and and hang the wordpress_list_comments() the following:

wp_list_comments('type=comment&callback=custom_comments&per_page=100&page=1');

The issue is, whenever someone posts a comments, the comment form appends '/comment-page-2/' towards the URL after posting the comment, despite the fact that I have specified that comments to become displayed on a single page.

Any idea things i might be missing?

Thank you for help

It is simple to switch off comment pagination inside your WordPress configurations. Visit Configurations > Discussion, then uncheck Break comments into pages with...

When the theme is well crafted, it will obey your configurations properly and display comments accordingly (and thus tthere shouldn't be have to edit the theme files).