I've got a Wordpress install on Godaddy which was on PHP4.

I've moved the Godaddy programming language to PHP 5.2 however the Wordpress update page still shows this error:

You can't update because WordPress 3.2.1 requires PHP version 5.2.4 or greater. You're running version 4.4.9.

The Godaddy account states PHP 5.2 has been used.

How do i update Wordpress now because the "Update" button is no more showing?

Despite the fact that GoDaddy may offer PHP5, it's something you need to occur your .htaccess file at the bottom of the site.

Add this to the peak of the .htaccess file:

AddType x-mapp-php5 .php
AddHandler application/x-httpd-php5 .php
AddHandler cgi-php5 .php

NOTE: you might not require the AddType line, in case your site provides a 500 error, then remove that line.