Getting a very baffling problem with permissions, WordPress and theme files.

I've got a fresh install of WordPress and attempted uploading the theme I designed for my client. It submitted fine however it does not display in the Manage Styles menu. I checked everything was submitted also it was. Checked permissions (even set these to 777 at some point) plus they were fine. However the theme does not appear.

Listed here are the various situations I have attempted:

  • While using Install Styles menu and uploading b .squat (unsuccessful)
  • Duplicate twentyten folder and contents (labored)
  • Duplicate twentyten folder and used my theme files (unsuccessful)
  • Duplicate twentyten folder and used my theme files as well as their style.css (unsuccessful)
  • Submitted my theme WITHOUT style.css (gave missing style.css error)
  • Submitted my theme WITHOUT style.css and set in twentyten/produced one on your own (both unsuccessful)

I am on my small clients MediaTemple hosting and I have never experienced this error. Their support has yet to return to us.

Does anybody have the identical problem? Solution? It is possible I can provide you with FTP access as needed.

CSS Mind (transformed values but format and everything remains the same):

/*

Theme Title: Example Theme

Theme URI: http://example.com/

Description: WordPress theme

Author: Company

Version: 1.

*/

Edit: Attempting to access the folder through my browser produces a 403 error (works fine on twentyten). style.css could be seen in the browser.

May be the theme folder title diverse from anything else? May be the Theme Title in fashion.cascading stylesheet diverse from anything else?

I wager you've some kind of special figures inside your templates. This once drove me nuts to locate. Look at your Template files and/or relabel them before the theme turns up. I made use of a german "ö" inside a templates title.

I'm speculating BOMs would be the problem. They screwed up my validation of the page once, when i attempted to get rid of the BOM. Use an editor and take away the BOMs. For Notepad++, the written text editor I personally use, I simply set the encoding to UTF-8 without BOM and saved. That solved my problem. Obviously, your text editor might be different.

I am presuming that you are with a couple kind of Linux web server, right? If you are utilizing a debian based one (like Ubuntu), you could attempt this from the terminal:

sudo chown -R world wide web-data:world wide web-data /var/world wide web/

After which it, after that you can put this within the terminal:

sudo chmod -R 0777 /var/world wide web/

Tell me whether it works now.

Possibly you're missing a needed template file?

In the very minimum, a WordPress Theme includes two files:

style.css

index.php

http://codex.wordpress.org/Theme_Development