I simply installed WordPress latest version, also installed OptimizePress Theme. I get the next error when attempting to include a brand new page in Word Press. Any help could be appreciated.

Warning: mkdir() [function.mkdir]: Permission refused in /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clscustomfields.php online 1578

Warning: mkdir() [function.mkdir]: No such file or directory in /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clscustomfields.php online 1581

Warning: mkdir() [function.mkdir]: No such file or directory in /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clscustomfields.php online 1584

Warning: mkdir() [function.mkdir]: Permission refused in /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clsblogfields.php online 174

Warning: mkdir() [function.mkdir]: No such file or directory in /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clsblogfields.php online 177

Warning: mkdir() [function.mkdir]: No such file or directory in /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clsblogfields.php online 180

Warning: mkdir() [function.mkdir]: Permission refused in /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clslpcustomfields.php online 1725

Warning: mkdir() [function.mkdir]: No such file or directory in /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clslpcustomfields.php online 1728

Warning: mkdir() [function.mkdir]: No such file or directory in /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clslpcustomfields.php online 1731

Warning: Cannot modify header information - headers already sent by (output began at /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clscustomfields.php:1578) in /home/admin/domain names/mywebsite.com/public_html/wordpress-includes/functions.php online 830

Warning: Cannot modify header information - headers already sent by (output began at /home/admin/domain names/mywebsite.com/public_html/wordpress-content/styles/OptimizePress/admin/clscustomfields.php:1578) in /home/admin/domain names/mywebsite.com/public_html/wordpress-includes/functions.php online 831

I believe you might have your permissions setup wrong in your server. Are you able to make sure that your wp-content/themes/OptimizePress directory has read/write permissions (usually 664)? If you do not understand how to do that, try right-hitting your directory inside your FTP application and seeking "View Info" or "Change Permissions" or something like that to that particular effect.

The permissions required for optimizepress theme can vary based on your webhost. Try altering wordpress-content folder to 755. If stil getting problems you may want to change uploads folder (inside wordpress-content folder) to 755 or 777.

I discovered a method to solve this: My page is placed as "public" As well as in the Launch/Gateway-configurations, I've ONLY selected: Activate gateway (and unchecked the 2 other fields in Launch/gateway configurations). This immediately reduced the problem.