I am using wordpress. Set up in the subfolder. (webroot/blog)

Permalinks was before: http ://www.mysite.com /blog/ sample-publish.html

I actived the network.

Permalinks after: http ://www.mysite.com /blog/blog/ sample-publish.html

wordpress-config.php

...
    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/blog/';
    define( 'DOMAIN_CURRENT_SITE', 'www.mysite.com' );
    define( 'PATH_CURRENT_SITE', '/blog/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
...

Primary Site Permalink Configurations http://i.stack.imgur.com/GyhWf.jpg


how to get it done?

http://www.mysite.com/blog/sample-post.html

Should you triggered network you can't possess the wordpress set up in a sub directory. It needs to maintain your html directory.

You might like to make use of a subdomain, or if you're not using network, disable it.

Yes, you are able to use a network inside a folder. Where people get confused within the alerts can there be part where they misinterpret the data given.

you can't use a network inside a folder and run the address from the root.

It has no relevence for your problem, but I am making clear it for other answerers.

the /blog/ inside your permalinks is put into the primary blog simply to prevent collisions. Search for the "remove blog permalink" wordpress plugin.

in 3. there is a bug permitting you to definitely remove this by hand.