I've lately moved my blog in one serever to a different. I'm now not able to revive my permalink structure.

Now my permalink strucure is becoming /?p=123. Whenever, I attempt to alter it holiday to a custom permalink structure, it throws 404 for the posts. Look into the blog at http://microreviews.org I've been instructed to result in the permalink structure as /?p=123. All of the records from search engines like google are however around the old structure /%postname%/

No plug ins for the similar appear to operate and i'm tied to the ?p=123 structure.

What must i do?

Presuming you are on Apache server:

  • You do not have the .htaccess file around the new server, or
  • the brand new server does not have mod_rewrite switched on, or
  • the brand new server ignores the .htaccess files, or
  • any combination of the aforementioned :)

Another option rather than using .htaccess (although Wordpress is made around modifying that file) you are able to go ahead and take items in the .htaccess file and add these to a directive inside your httpd.conf (or virtual host config file). This method requires more use of your apache installation (i.e. may possibly not use some hosting solutions), but based on the Apache httpd documentation it's safer and fewer focus on the server since apache will scan every directory for .htaccess files every time a page is utilized and it'll re-load the .htaccess file(s) each time the page is utilized too. When the access is defined in to the server config then its loaded once at apache start-up (or on the server reload) and that is it.

For instance: In case your .htaccess file contained the next for that /www/htdocs/example directory

AddType text/example .exm

Then your following inside your httpd.conf file could be equivalent

<Directory /www/htdocs/example>
AddType text/example .exm
</Directory>

The approach of editing your primary configuration rather than .htaccess doesn't need that you simply specify AllowOverride to something apart from None.

Within this situation, you will still need mod_rewrite enabled for permalinks to operate properly.