I moved my website from slichost to Amazon . com ec2. After moving i made necessary configurations for wordpress. My first page for wordpress works fine, however the permalinks aren't working. Can anybody please tell me what changes are essential to create the permalinks working.

Thanks

Try adding index.php/ prior to the permalink path.

Look at your apache configuration and verify that for that directory that you store your Wordpress installation you've following configurations enabled (most likely you'll have more configuration choices for the particular directory, but fundamental essentials minimum needed for Wordpress fancy permalinks):

<Directory var/www/>
FollowSymLinks
AllowOverride All
</Directory>