I'm acquainted with previous Wordpress contractors, however in this latest version I have hit new things which i aren't seeing recorded.

I'm trying to set up wordpress to MAMP as my localhost and I am getting errors that indicate the table creation has unsuccessful.

PHP: 5.2.11

MySQL: 5.1.37

I have used the installer interface to create db configurations and I have also attempted it by hand, without any difference.

I recieve the next errors around the installation success screen. The tables wordpress-commentmeta and wordpress-links are produced and i'm given a login/password - despite the fact that tables for customers aren't be produced.

WordPress database error: [MyISAM table 'wp_terms' is in use (most likely by a MERGE table). Try FLUSH TABLES.]
CREATE TABLE wp_terms ( term_id bigint(20) unsigned NOT NULL auto_increment, name varchar(200) NOT NULL default '', slug varchar(200) NOT NULL default '', term_group bigint(10) NOT NULL default 0, PRIMARY KEY (term_id), UNIQUE KEY slug (slug), KEY name (name) ) DEFAULT CHARACTER SET utf8

WordPress database error: [MyISAM table 'wp_term_taxonomy' is in use (most likely by a MERGE table). Try FLUSH TABLES.]
CREATE TABLE wp_term_taxonomy ( term_taxonomy_id bigint(20) unsigned NOT NULL auto_increment, term_id bigint(20) unsigned NOT NULL default 0, taxonomy varchar(32) NOT NULL default '', description longtext NOT NULL, parent bigint(20) unsigned NOT NULL default 0, count bigint(20) NOT NULL default 0, PRIMARY KEY (term_taxonomy_id), UNIQUE KEY term_id_taxonomy (term_id,taxonomy), KEY taxonomy (taxonomy) ) DEFAULT CHARACTER SET utf8

WordPress database error: [MyISAM table 'wp_term_relationships' is in use (most likely by a MERGE table). Try FLUSH TABLES.]
CREATE TABLE wp_term_relationships ( object_id bigint(20) unsigned NOT NULL default 0, term_taxonomy_id bigint(20) unsigned NOT NULL default 0, term_order int(11) NOT NULL default 0, PRIMARY KEY (object_id,term_taxonomy_id), KEY term_taxonomy_id (term_taxonomy_id) ) DEFAULT CHARACTER SET utf8

WordPress database error: [MyISAM table 'wp_comments' is in use (most likely by a MERGE table). Try FLUSH TABLES.]
CREATE TABLE wp_comments ( comment_ID bigint(20) unsigned NOT NULL auto_increment, comment_post_ID bigint(20) unsigned NOT NULL default '0', comment_author tinytext NOT NULL, comment_author_email varchar(100) NOT NULL default '', comment_author_url varchar(200) NOT NULL default '', comment_author_IP varchar(100) NOT NULL default '', comment_date datetime NOT NULL default '0000-00-00 00:00:00', comment_date_gmt datetime NOT NULL default '0000-00-00 00:00:00', comment_content text NOT NULL, comment_karma int(11) NOT NULL default '0', comment_approved varchar(20) NOT NULL default '1', comment_agent varchar(255) NOT NULL default '', comment_type varchar(20) NOT NULL default '', comment_parent bigint(20) unsigned NOT NULL default '0', user_id bigint(20) unsigned NOT NULL default '0', PRIMARY KEY (comment_ID), KEY comment_approved (comment_approved), KEY comment_post_ID (comment_post_ID), KEY comment_approved_date_gmt (comment_approved,comment_date_gmt), KEY comment_date_gmt (comment_date_gmt) ) DEFAULT CHARACTER SET utf8

WordPress database error: [MyISAM table 'wp_options' is in use (most likely by a MERGE table). Try FLUSH TABLES.]
CREATE TABLE wp_options ( option_id bigint(20) unsigned NOT NULL auto_increment, blog_id int(11) NOT NULL default '0', option_name varchar(64) NOT NULL default '', option_value longtext NOT NULL, autoload varchar(20) NOT NULL default 'yes', PRIMARY KEY (option_id), UNIQUE KEY option_name (option_name) ) DEFAULT CHARACTER SET utf8

WordPress database error: [MyISAM table 'wp_postmeta' is in use (most likely by a MERGE table). Try FLUSH TABLES.]
CREATE TABLE wp_postmeta ( meta_id bigint(20) unsigned NOT NULL auto_increment, post_id bigint(20) unsigned NOT NULL default '0', meta_key varchar(255) default NULL, meta_value longtext, PRIMARY KEY (meta_id), KEY post_id (post_id), KEY meta_key (meta_key) ) DEFAULT CHARACTER SET utf8

WordPress database error: [MyISAM table 'wp_posts' is in use (most likely by a MERGE table). Try FLUSH TABLES.]
CREATE TABLE wp_posts ( ID bigint(20) unsigned NOT NULL auto_increment, post_author bigint(20) unsigned NOT NULL default '0', post_date datetime NOT NULL default '0000-00-00 00:00:00', post_date_gmt datetime NOT NULL default '0000-00-00 00:00:00', post_content longtext NOT NULL, post_title text NOT NULL, post_excerpt text NOT NULL, post_status varchar(20) NOT NULL default 'publish', comment_status varchar(20) NOT NULL default 'open', ping_status varchar(20) NOT NULL default 'open', post_password varchar(20) NOT NULL default '', post_name varchar(200) NOT NULL default '', to_ping text NOT NULL, pinged text NOT NULL, post_modified datetime NOT NULL default '0000-00-00 00:00:00', post_modified_gmt datetime NOT NULL default '0000-00-00 00:00:00', post_content_filtered text NOT NULL, post_parent bigint(20) unsigned NOT NULL default '0', guid varchar(255) NOT NULL default '', menu_order int(11) NOT NULL default '0', post_type varchar(20) NOT NULL default 'post', post_mime_type varchar(100) NOT NULL default '', comment_count bigint(20) NOT NULL default '0', PRIMARY KEY (ID), KEY post_name (post_name), KEY type_status_date (post_type,post_status,post_date,ID), KEY post_parent (post_parent) ) DEFAULT CHARACTER SET utf8

WordPress database error: [MyISAM table 'wp_users' is in use (most likely by a MERGE table). Try FLUSH TABLES.]
CREATE TABLE wp_users ( ID bigint(20) unsigned NOT NULL auto_increment, user_login varchar(60) NOT NULL default '', user_pass varchar(64) NOT NULL default '', user_nicename varchar(50) NOT NULL default '', user_email varchar(100) NOT NULL default '', user_url varchar(100) NOT NULL default '', user_registered datetime NOT NULL default '0000-00-00 00:00:00', user_activation_key varchar(60) NOT NULL default '', user_status int(11) NOT NULL default '0', display_name varchar(250) NOT NULL default '', PRIMARY KEY (ID), KEY user_login_key (user_login), KEY user_nicename (user_nicename) ) DEFAULT CHARACTER SET utf8

WordPress database error: [MyISAM table 'wp_usermeta' is in use (most likely by a MERGE table). Try FLUSH TABLES.]
CREATE TABLE wp_usermeta ( umeta_id bigint(20) unsigned NOT NULL auto_increment, user_id bigint(20) unsigned NOT NULL default '0', meta_key varchar(255) default NULL, meta_value longtext, PRIMARY KEY (umeta_id), KEY user_id (user_id), KEY meta_key (meta_key) ) DEFAULT CHARACTER SET utf8

After which alot of messages saying updates/card inserts etc unsuccessful since the table does not exist.

Anybody experienced this before?

EDIT: MAMP reviews port 8889 for mysql, and so i transformed the hostname in wordpress-config to localhost:8889. Which has not labored.

EDIT: I fixed this. I'd an earlier database for wordpress that we erased and re-produced frequently attempting to solve this issue. Apparently removing it had not been adequate because the problem was solved by developing a database known as newwordpress and taking advantage of that rather.

MySQL must retain some data from erased databases.