I've got a WordPress site running on the production server which i lately replicated to my Mac. When I wish to see the site on my small Mac, Time passes here and delay pills work fine:

http://localhost/jasonswett.net/web/

However after i attempt to view any publish it does not work. Basically click here

http://localhost/jasonswett.net/web/tar-examples/

I recieve a mistake that states, "The asked for URL /jasonswett.internet/web/tar-good examples/ wasn't available on this server."

I understand mod_rewrite is enabled because I view it after i perform a phpinfo(). My htaccess file is really a straight copy from production.

Any idea exactly what the problem might be?

Perhaps you have up-to-date the wordpress location designs inside your database that you simply replicated?

UPDATE wp_posts SET guid = replace(guid, 'http://old.net','http://new.net');
UPDATE wp_posts SET post_content = replace(post_content, 'http://old.net', 'http://new.net');
UPDATE wp_postmeta SET meta_value = replace(meta_value, 'http://old.net', 'http://new.net');
UPDATE wp_options SET option_value = replace(option_value, 'http://old.net', 'http://new.net');

This can be a necessary step when moving wordpress in one domain to a different, including production to local.

Otherwise, perhaps you have checked that the .htaccess on local has been read whatsoever? Try setting a PHP configuration value inside it to see if it's acquired by phpinfo(). You will find lots of ways this may be wrong: 1. You may want to adjust the possession of .htaccess towards the user your apache runs just like chown and chmod 640 it too so read permissions is going to be granted for owner and group. 2. You may want to set the AllowOverride directive inside your httpd.conf 3. Make sure that you haven't modified AccessFileName directive.

Last, what goes on should you disable permalinks in wordpress?

It may sound such as the AllowOverride directive isn't correctly set for your folder. Inside your Apache configuration, you need to make certain the Directory or Vhost you are using for that primary domain has got the AllowOverride set to any or all

http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride