my website (http://blog.datisdesign.com) is working correctly in Opera and IE9, however in IE8,7 the slider wordpress plugin on the top of website, isn't working correctly and shows me this error :

SCRIPT438: Object doesn't support property or method 'slice' 
jquery.js?ver=1.4.4, line 149 character 392

So what can I actually do ?

Because script 438 (whatever that's) attempts to use Array:slice, which is not implemented in versions of IE just before 9.

Try adding this before your slider js file.

if (!Array.prototype.slice) {
    Array.prototype.slice = function (i, i2) {
        var cake = [];
        for (; i < i2; i++)
            cake.push(this[i]);
        return cake;
    };
}

It will repair it, no promises though.

Whether it's still no longer working, it should be String:slice. Try..

if (!String.prototype.slice) {
    String.prototype.slice = function (i, i2) {
        var cake = "";
        for (; i < i2; i++)
            cake += this.chatAt(i);
        return cake;
    };
}