I looked but could not discover the response to this unique question.

I am running XAMPP for home windows and it is working fine on my small local machine however when I attempt to gain access to Wordpress with the network all I recieve may be the index page. The web pages aren't formatted correctly and also the links aren't effective. PHP is not dealing with the network.

This creates my local machine: "http://192.168.x.xxx/mysite/wordpress/" however when being able to access it with the network, I recieve the issue above.

How do i get this work to ensure that someone within the next office can observe the websites correctly too?

Perhaps you have attempted searching here, you will find looooooads of hits with this on the internet : http://www.google.co.uk/search?gcx=c&sourceid=chrome&ie=UTF-8&q=xampp+not+working+over+lan

Following a quick browse it seems the firewall on your computer is most likely obstructing it, as someone noted 'allowed port 80 restricting the scope to my subnet' , try permitting incoming traffic on port 80, restrict it to simply the local lan though.

Just like a fast test try turning your firewall off totally and find out whether it works, whether it does you realize its a firewall problem and you'll then have to open ports its obstructing.

The web pages aren't formatted propertly because CSS isn't loaded.

In wordpress, setting, make certain you alter the road to

192.168.x.xxx

The road there's usually localhost. Even though they both same factor, localhost isn't construed because the IP. Like smart localhost isn't construed as the computer title too.

I would suggest to alter localhost for your computer after which access your site using your computer title, not the Ip.

Also make certain you've shared the folder contain wordpress.