I'm looking to get XDebug focusing on my local wamp installation (Uniform Server 8).

However, if I put
xdebug.remote_enable=1

during my php.ini, that is needed for my IDE to make use of xdebug, loading the web pages will get really slow as with 5 seconds per page slow. The debugger works though.

I've not used xdebug before but I know it normally should not take this lengthy. I am confident it could have something related to while using symfony2 framework.

Does anybody know what's leading to this?

It's maybe since this is what it really does!

Look into the default storage spot for xdebug logs (the majority of the occasions /tmp/xdebug/something) which on Home windows could be different things than you are on unix/linux systems.

set these inside your php.ini if you would like them placed/named elsewhere:

xdebug.profiler_output_dir Type: string, Default value: /tmp Your directory in which the profiler output is going to be written to, make certain the user who the PHP is going to be running as has write permissions to that particular directory. This setting cannot be occur your script with ini_set().

xdebug.profiler_output_title Type: string, Default value: cachegrind.out.%p

This setting determines the title from the file that's accustomed to dump traces into. The setting identifies the format with format specifiers, much like sprintf() and strftime(). You will find several format specifiers you can use to format the file title.

Producing these files is taxing for your system. However these are what you ought to profile your code.

Also go read http://xdebug.org/docs before you decide to really utilize it again to ensure that guess what happens exactly you are attempting to complete.