On all except page-1 my table doesn't pad like I tell it to. I actually do possess a "first" along with a "Rest" understood to be

<!-- layout for the first page -->
        <fo:simple-page-master master-name="first"
              page-height="11in"
              page-width="8.5in"
              margin-top="1cm"
              margin-bottom="2cm"
              margin-left="2.5cm"
              margin-right="2.5cm">
          <fo:region-body margin-top="3cm"/>
          <fo:region-before extent="2cm"/>
          <fo:region-after extent=".1cm"/>
        </fo:simple-page-master>

        <!-- layout for the other pages -->
        <fo:simple-page-master master-name="rest"
                      page-height="11in"
                      page-width="8.5in"
                      margin-top="1cm"
                      margin-bottom="2cm"
                      margin-left="2.5cm"
                      margin-right="2.5cm">
          <fo:region-body margin-top="3cm"/>
          <fo:region-before extent="2cm"/>
          <fo:region-after extent=".1cm"/>
        </fo:simple-page-master>

But, I do not observe how this could affect my padding.

<fo:block>
            <!-- table start -->
            <fo:table table-layout="fixed" width="100%" border-collapse="separate" padding-after="1em">
              <fo:table-column column-width="15mm"/>
              <fo:table-column column-width="46mm"/>
              <fo:table-column column-width="28mm"/>
              <fo:table-column column-width="22mm"/>
              <fo:table-column column-width="19mm"/>
              <fo:table-column column-width="30mm"/>

              <fo:table-header>
                <fo:table-cell>
                  <fo:block font-weight="bold" border-width="0.5mm" border-style="solid" >
                    <fo:inline padding-left="1mm">Model</fo:inline>
                  </fo:block>
                </fo:table-cell>
                <fo:table-cell>
                  <fo:block font-weight="bold" border-width="0.5mm" border-style="solid" border-left="none">
                    <fo:inline padding-left="2mm">Description</fo:inline>
                  </fo:block>
                </fo:table-cell>
                <fo:table-cell>
                  <fo:block font-weight="bold" border-width="0.5mm" border-style="solid" padding-left=".1mm" border-left="none">
                    <fo:inline padding-left="2mm">Material</fo:inline>
                  </fo:block>
                </fo:table-cell>

Note the padding-left attribute. Why does not it get respected on basically page one?

UPDATE
I observed this only happens on "overflow pages". When my table has enough data to wrap to a different page. If it is a brand new table, the issue disappears.

This really is most likely a limitation from the XSL FO processor implementation, APACHE FOP. I'll contact them.